it appears that wordpress version 2.1.1 is not safe no more.
wordpress has requested all users who are running version 2.1.1 to upgrade to version 2.1.2 immediately.
they suggest a full overwrite of old files, especially those in wp-includes.

2007.03.03